{"_id":"588f722bbcace50f0052b9fe","user":"565f3941ea46251700972783","category":{"_id":"588f722bbcace50f0052b9e7","version":"588f722bbcace50f0052b9e1","project":"565f5fa26bafd40d0030a064","__v":0,"sync":{"url":"","isSync":false},"reference":false,"createdAt":"2015-12-17T21:29:23.551Z","from_sync":false,"order":5,"slug":"server-installation-configuration","title":"Self Hosting"},"parentDoc":null,"__v":0,"project":"565f5fa26bafd40d0030a064","version":{"_id":"588f722bbcace50f0052b9e1","project":"565f5fa26bafd40d0030a064","__v":1,"createdAt":"2017-01-30T17:04:43.410Z","releaseDate":"2017-01-30T17:04:43.410Z","categories":["588f722bbcace50f0052b9e2","588f722bbcace50f0052b9e3","588f722bbcace50f0052b9e4","588f722bbcace50f0052b9e5","588f722bbcace50f0052b9e6","588f722bbcace50f0052b9e7"],"is_deprecated":false,"is_hidden":false,"is_beta":false,"is_stable":true,"codename":"","version_clean":"5.3.0","version":"5.3.0"},"updates":["57e5486700c8680e00fae7d2","57ea8d2c802e4a17009181ad","57eaece643d2780e008e7a76"],"next":{"pages":[],"description":""},"createdAt":"2015-12-04T21:41:09.740Z","link_external":false,"link_url":"","githubsync":"","sync_unique":"","hidden":false,"api":{"results":{"codes":[]},"settings":"","auth":"required","params":[],"url":""},"isReference":false,"order":3,"body":"## Operating System Requirements for nanoscale.io Server\n[block:parameters]\n{\n  \"data\": {\n    \"h-0\": \"Operating System\",\n    \"h-1\": \"Distribution / Version\",\n    \"0-0\": \"Linux\",\n    \"0-1\": \"RedHat Enterprise 7.1 (64-bit), Ubuntu Server 14.04 LTS (32-bit or 64-bit)\",\n    \"1-0\": \"Linux ARM\",\n    \"1-1\": \"Debian wheezy armhf, Raspbian 2015 (for ARMv6 or ARMv7 devices)\",\n    \"2-0\": \"Mac OSX\",\n    \"2-1\": \"10.8 (Mountain Lion), 10.9 (Mavericks), 10.10 (Yosemite)\",\n    \"3-0\": \"Microsoft Windows\",\n    \"3-1\": \"7, 8 (32-bit or 64-bit)\",\n    \"4-0\": \"Microsoft Windows Server\",\n    \"4-1\": \"2012\"\n  },\n  \"cols\": 2,\n  \"rows\": 5\n}\n[/block]\n## Database Requirements for Configuration Repository\nApplicable when running in server modes.\n[block:parameters]\n{\n  \"data\": {\n    \"h-0\": \"Database\",\n    \"h-1\": \"Version\",\n    \"0-0\": \"PostgreSQL\",\n    \"0-1\": \"9.4+\"\n  },\n  \"cols\": 2,\n  \"rows\": 1\n}\n[/block]\n## Minimum Browser Requirements for nanoscale.io Dashboard\n[block:parameters]\n{\n  \"data\": {\n    \"h-0\": \"Browser\",\n    \"h-1\": \"Version\",\n    \"0-0\": \"Chrome\",\n    \"0-1\": \"41\",\n    \"1-0\": \"Safari\",\n    \"1-1\": \"8.0.4\",\n    \"2-0\": \"FireFox\",\n    \"2-1\": \"36.0.4\",\n    \"3-0\": \"Internet Explorer\",\n    \"3-1\": \"11\"\n  },\n  \"cols\": 2,\n  \"rows\": 4\n}\n[/block]\n## Supported Remote Endpoints\n[block:parameters]\n{\n  \"data\": {\n    \"h-0\": \"Endpoint\",\n    \"0-0\": \"MongoDB\",\n    \"h-1\": \"Version\",\n    \"1-0\": \"Microsoft SQL Server\",\n    \"0-1\": \"2.0+\",\n    \"1-1\": \"2005+\",\n    \"2-0\": \"MySQL\",\n    \"2-1\": \"4.1+\",\n    \"3-0\": \"PostgreSQL\",\n    \"3-1\": \"7.4+\",\n    \"4-0\": \"SOAP\",\n    \"4-1\": \"1.1 and 1.2 (requires Java runtime and JDK, see more info in the [SOAP Remote Endpoints](doc:soap-remote-endpoints) section).\"\n  },\n  \"cols\": 2,\n  \"rows\": 5\n}\n[/block]","excerpt":"","slug":"supported-platforms","type":"basic","title":"Supported Platforms"}

Supported Platforms


## Operating System Requirements for nanoscale.io Server [block:parameters] { "data": { "h-0": "Operating System", "h-1": "Distribution / Version", "0-0": "Linux", "0-1": "RedHat Enterprise 7.1 (64-bit), Ubuntu Server 14.04 LTS (32-bit or 64-bit)", "1-0": "Linux ARM", "1-1": "Debian wheezy armhf, Raspbian 2015 (for ARMv6 or ARMv7 devices)", "2-0": "Mac OSX", "2-1": "10.8 (Mountain Lion), 10.9 (Mavericks), 10.10 (Yosemite)", "3-0": "Microsoft Windows", "3-1": "7, 8 (32-bit or 64-bit)", "4-0": "Microsoft Windows Server", "4-1": "2012" }, "cols": 2, "rows": 5 } [/block] ## Database Requirements for Configuration Repository Applicable when running in server modes. [block:parameters] { "data": { "h-0": "Database", "h-1": "Version", "0-0": "PostgreSQL", "0-1": "9.4+" }, "cols": 2, "rows": 1 } [/block] ## Minimum Browser Requirements for nanoscale.io Dashboard [block:parameters] { "data": { "h-0": "Browser", "h-1": "Version", "0-0": "Chrome", "0-1": "41", "1-0": "Safari", "1-1": "8.0.4", "2-0": "FireFox", "2-1": "36.0.4", "3-0": "Internet Explorer", "3-1": "11" }, "cols": 2, "rows": 4 } [/block] ## Supported Remote Endpoints [block:parameters] { "data": { "h-0": "Endpoint", "0-0": "MongoDB", "h-1": "Version", "1-0": "Microsoft SQL Server", "0-1": "2.0+", "1-1": "2005+", "2-0": "MySQL", "2-1": "4.1+", "3-0": "PostgreSQL", "3-1": "7.4+", "4-0": "SOAP", "4-1": "1.1 and 1.2 (requires Java runtime and JDK, see more info in the [SOAP Remote Endpoints](doc:soap-remote-endpoints) section)." }, "cols": 2, "rows": 5 } [/block]